【NW】RouterBoardにおけるMTU/MRU問題 
 ずいぶん前に貸与されてから塩漬けになっていたRB2011ですが、裏ルータ的な何かとしていざ使ってみたところ接続が不安定だった為メモしておきます。
 結論から書くと、所謂MTU/MRU1454問題でした。まあこれだけ書けば分かる人には終了ですね。


 RBの仕様は、PPPoEセッション上のMTU/MRUがデフォルトで1480で設定されるのですが、NTT網内のMTU/MRUが最大1454であるため、フラグメントが起きてしまうようなページを開いてしまうと、ページが不完全のまま表示されるかタイムアウトしてしまうのです。
 
 具体的にはこのブログのTwitterプラグインで問題が起きます。なので、同様の問題があって検索した人がこのページを開けないという残念な問題が起きます。(ぇ もしかしたら不完全ながらも表示できるかもしれませんが。

 このページをRB2011から別のPPPoEセッションを張りWANから参照してみた際のログですが、デフォルトの設定だと、以下のように、特定のファイルだけいつまでもファイルが降ってきません。




 Pingなどが途切れることはなく、なおかつ問題ないページは問題なく表示されるのですが、一部の広告表示用Javascriptが挿入されているようなページだとタイムアウト待ちをするため、ブラウジングの際にページの表示速度が非常にストレスフルな表示速度になります。

 内側のLinuxから行ったtracepathの結果やWebFigの表示結果を見る限りは、MTUの値は1480のデフォルトでも正しく1454で受け取るようなのですが、MRUの値は1480のままであり、これが問題になるようです。





 解決するには、PPPoEインターフェースのMRUを変更します。




 MTUは自動設定されますが、一応変えておいたほうが無難だと思われます。OK/Applyをクリックすることにより設定を反映しますが、その際にPPPoEを切ってから再度接続を行うため、ISPによってはIPが変わります。(OCNの環境だとIPが変わりました。)

 変更後、見た限りWebページによって表示が遅い問題は解決しました。現在、2つのIFを束ねたBonding IF上に タグVLANを作成し、LANセグメントをいくつかとWANセグメントインターフェースを作成していますが、この構成でも問題なく動いています。

 完全に接続ができないわけではなく、さらに回線速度測定ページなどでは問題なく速度が出てしまうため、この問題に気が付きませんでした。
 悩んでいたところ解決の糸口を享受していただいた@neko6_tweetさんに感謝です。

 しかし、1.6万前後でここまでVLANなどがいじれるルーターはなかなかないですね。ちらっと見たところポリシーベースルーティング(PBR)も当たり前のようにできるようですし、ネットワークにおける大体のやりたいことをどうにかする方法があるようです。これは魅力に取りつかれる人が多いのも納得です。





[ 1 コメント ] ( 1101 回表示 )   |  このエントリーのURL  |  $star_image$star_image$star_image$star_image$star_image ( 3 / 545 )  |  
【HW】ECS LIVA(B3 2G 32G) を試してみる 前編 



 巷で話題のECS LivaをついIYHしてしまいました。秋葉原Buymoreの展示機を見てから、欲しいなと思っていつつも中々在庫がどこにも入ってこなかったのですが、仕事帰りに何となくドスパラを見たらあったのでつい…。

 個人的に、何に使うかよりも、HWとしてどの程度使えるのか興味があったため、この評価ボード(違う)のレビューしてみます。画像の元ネタが一発で分かったような人には多分物足りないと思いますが。どうでも良いですが、元ネタは左手だったんですね。頭にあるイメージで右だと思って思いつきで突貫で作って、作ったあと気がつきました。ほんとどうでも良い。

 思ったよりもハマりポイントが多かったため、まずはHWの部分です。

もっと読む...

[ コメントを書く ] ( 1426 回表示 )   |  このエントリーのURL  |  $star_image$star_image$star_image$star_image$star_image ( 3.1 / 422 )  |  
【その他】ごみスクリプト置き場 
 某所にいたときに不毛な作業を少しでも楽にしようと足掻いた時に作ったゴミを置いておきます。たまにこれをベースに何かを作ったりするので主に自分のためのメモですが。
 内容としては、Expectで複数サーバに対して同一コマンドをsuして実行するだけのゴミと複数のサーバから一か所にファイルをSCPで集めるか送るだけのゴミです。

もっと読む...

[ コメントを書く ] ( 1056 回表示 )   |  このエントリーのURL  |  $star_image$star_image$star_image$star_image$star_image ( 2.9 / 479 )  |  
RouterBoard RB2011UiASに触ってみた 
 あけましておめでとうございました(過去形)。つかもう2月ですね。久しぶりの記事です。

 今年第一の記事は、評価用のRB2011UiAS-RMを株式会社シー アイオープラスさんから貸していただいた(ありがとうございます!)ので、一部界隈でアツいRouterBoardについてファーストインプレッションと簡単なベンチマークをしてみました。

 本来だと先先週の初めくらいには評価を終わらせようと思っていたのですが風邪引いたり忙しかったり現場がクソ色々大変で全く何も出来ていなかったという…。



もっと読む...

[ 2 コメント ] ( 3182 回表示 )   |  このエントリーのURL  |  $star_image$star_image$star_image$star_image$star_image ( 3.1 / 527 )  |  
【H/W】ThinkpadX61/60,Compaq 2510pでWindows8利用時に有線LANが不安定な問題 
 手元にあるX61と2510PにWin8をずいぶん前に入れて見たのですが、有線がリンクアップするとプチフリのような不定期なフリーズと、たまにDPC Watchdog Violationというブルーバックを吐いて再起動してしまうという問題がありました。問題の再現はNICにIntel 82566チップを使ってると起きるようでした。

 物理層に問題があるのかと、適当なLinuxを突っ込みiperfを一日かけてみたのですがそちらでは問題が無く、Windows7でも問題なく動いていました。そのため、様々なドライバやファームを試したのですが結局解決せず、無線のみ使用時は問題がなかったので、ごまかして使っていました。8.1が出たので8.1なら直っているかと思い試したのですが、再現してしまいました。そして、 久々に調べたら解決方法があったのでメモとして書いておきます。

 内容としては以下に書いてあるままです。

windows 8 with Intel 82566MM Network Card is not usable

まず、ネットワーク接続→プロパティー→構成なりWin+X→Mなりでドライバのプロパティーを開きます。該当のNICの「詳細」タブにある「ハードウェアID」を選択して表示させます。




この一番上の値を参考に、レジストリの以下の値を開きます。

HKEY_LOCAL_MACHINE\
 →SYSTEM\
  →CurrentControlSet\
   →Enum\
    →PCI\
     →VEN_8086&DEV_XXXX&...\
      →3&33fd14ca&0&C8\
       →Device Parameters\
        →InterruptManagement\
         →MessageSignaledInterruptProperties


 このVEN_と言うのが前段階で開いたハードウェアIDになります。ここの、MSISupportedが1になっているのを0に変更します。その後、変更を反映させるため再起動します。




 再起動後、おそらく問題は収まると思います。少なくとも、自分はこの変更によりX61/2510Pにて発生していた上記問題は再現しなくなりました。

 レジストリの位置を一々ググり直すのが面倒なのでメモとして書いておきます。

 以上です。

[ コメントを書く ] ( 2147 回表示 )   |  このエントリーのURL  |  $star_image$star_image$star_image$star_image$star_image ( 3 / 544 )  |  

<<最初へ <戻る | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 進む> 最後へ>>